В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
диана2263
диана2263
07.03.2023 11:59 •  Информатика

Написать программу решения : с клавиатуры вводят 9 вещественных чисел. занести в типизированный файл только отрицательные из введённых чисел. при форматирование файла учесть, что в файле данные должны быть записаны в строку.

Ответ:
Kakakkakaka
Kakakkakaka
21.07.2020 10:03
Var
  i:integer;
  n:real;
  f:file of real;
begin
  Assign(f,'in.dat');
  Rewrite(f);
  Writeln('Введите 9 вещественных чисел');
  for i:=1 to 9 do begin Read(n); Write(f,n) end;
  Close(f)
end.

Пример ввода:
Введите 9 вещественных чисел
2 -5 1.45 -81.34 5.63e-10 0 -13.45e12 17.5353 -12e-3 1000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?