В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Как составить программу вычисления и выдачи на печать суммы (или произведения) n элементов бесконечного числового ряда .следует пользоваться операторами цикла for: y=125(-25)5(-1)0,

Ответ:
allalal1
allalal1
02.10.2020 11:52
1  var k,i,n,c:integer;
2     p,w:real;
3  begin
4  repeat
5  write('k>-3 k=');
6  readln(k);
7  until k>-3;
8  w:=0;
9  c:=1;
10  for i:=-3 to k do
11    begin
12     c:=-c;{-1^i}
13     p:=1;
14     for n:=i to 2*k do
15     if n<>2 then p:=p*(n*n*n-8);
16     if i<>5 then w:=w+(c/sqr(i-5))*p;
17    end;
18   write('W=',w:0:4)
19   end.

Это?
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?