В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nekit1205
nekit1205
15.02.2023 08:13 •  Информатика

По языку паскаля, завтра уже сдать надо. 1) напишите программу, которая выводит код введенного пользователем символа. программа должна завершать свою работу в результате ввода, например точки. 2)напишите программу, которая выводит на экран первую часть таблицы кодировки символов (от 0 до 127). таблица должна состоять из восьми колонок и шестнадцати строк. в первой колонке должны быть символы с кодом от 0 до 15, во второй от 16 до 31 и т.д.

Ответ:
galaxykill
galaxykill
21.07.2020 01:42
1 задача:
program znan1;
uses crt;
var a:char;
begin
clrscr;
readln(a);
while a<>'.' do
begin
writeln(ord(a));
readln(a);
end;
end.

2 задача:
program znan2;
uses crt;
var i,j:integer;
begin
for i:=1 to 16 do
begin
for j:=1 to 8 do
begin
write((i*j-1):5,'-',chr(i*j-1));
end;
writeln;
end;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?