В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
N1R2
N1R2
24.05.2021 23:26 •  Информатика

Дан массив из n чисел. n - четное. написать программу, меняющую местами элементы с четными и нечетными номерами. оч надо

Ответ:
absolado14
absolado14
20.07.2020 21:00
Program Yolo;
Uses Crt;
Const N=16;
Var Mass: array [1..n] of integer;
    Back: integer;
    i: byte;
Begin
 Randomize;
 ClrScr;
 Writeln('Исходная матрица [-15;15]: ');
 For i:=1 to N do
  Begin
   Mass[i]:=Random(31)-15;
   Write(Mass[i]:4);
  End;
 Writeln;
 For i:=1 to N do
   If i mod 2<>0 then
    Begin
     Back:=Mass[i];
     Mass[i]:=Mass[i+1];
     Mass[i+1]:=Back;
    End;
 Writeln('Отформотированный матрица: ');
 For i:=1 to N do
  Write(Mass[i]:4);
 Readln;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?