В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
198565
198565
28.08.2022 12:51 •  Информатика

Составить программу в паскаль: даны 4 числа,выделить целые части и найти среднее арифметическое этих чисел.

Ответ:
basgal67
basgal67
20.07.2020 19:30
Var
  i:integer;
  a,c:real;
begin
  c:=0;
  Writeln('Введите четыре произвольных числа');
  for i:=1 to 4 do
  begin
    Read(a); c:=c+Int(a)
  end;
  c:=c/4;
  Writeln('Среднее арифметическое равно ',c)
end.

Тестовое решение:
Введите четыре произвольных числа
4.7 5.03 4.12 5
Среднее арифметическое равно 4.5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?