В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aziret31101
aziret31101
03.11.2021 08:45 •  Информатика

Составить программу вычисления значений квадратичной функции на заданном интервале

Ответ:
visokon1111
visokon1111
20.07.2020 19:24
Var
  a,b,c,p,q,h,x,y:real;
begin
  Write('Введите через пробел коэффициенты a,b,c: ');
  Read(a,b,c);
  Write('Введите через пробел границы интервала [p;q]: ');
  Read(p,q);
  Write('Введите шаг табуляции h: ');
  Read(h);
  x:=p;
  while x<=q+h/10 do begin
    y:=c+x*(b+x*a); { схема Горнера для вычисления значения полиномов }
    Writeln(x:15:8,y:15:8);
    x:=x+h
  end
end.

Тестовое решение:
Введите через пробел коэффициенты a,b,c: -4 2.7 10.582
Введите через пробел границы интервала [p;q]: -3 2.5
Введите шаг табуляции h: 0.25
    -3.00000000   -33.51800000
    -2.75000000   -27.09300000
    -2.50000000   -21.16800000
    -2.25000000   -15.74300000
    -2.00000000   -10.81800000
    -1.75000000    -6.39300000
    -1.50000000    -2.46800000
    -1.25000000     0.95700000
    -1.00000000     3.88200000
    -0.75000000     6.30700000
    -0.50000000     8.23200000
    -0.25000000     9.65700000
     0.00000000    10.58200000
     0.25000000    11.00700000
     0.50000000    10.93200000
     0.75000000    10.35700000
     1.00000000     9.28200000
     1.25000000     7.70700000
     1.50000000     5.63200000
     1.75000000     3.05700000
     2.00000000    -0.01800000
     2.25000000    -3.59300000
     2.50000000    -7.66800000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?