В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
jonjonson
jonjonson
29.02.2020 03:17 •  Информатика

Томата вить программу на паскале используя подпрограммы-процедуры составить программу для формирования массива элементы которого являются цифры заданного числа n

Ответ:
sapeglub
sapeglub
20.07.2020 19:00
 type   
mas = array [1..10] of integer; 
var   
m : mas;   
a,l : integer;  

function re () : integer;         //Считываем число
var    a : integer; 
begin   
writeln ('Введите число');   
readln (a);   
Result :=a; 
end;   

function C(var m : mas; a : integer) : integer;  //Разбиваем на числа
var     i : integer;   
begin   
i := 0;   
While a > 0 do     
begin     
i := i +1;     
m[i] := a mod 10;     
a := a div 10;                 
end;   
Result := i;   
end;    
procedure wr (a : mas; l : integer);   // Вывод массива
var     i : integer;   
begin   
writeln ('Resultat :');    
for i := 1 to l do     
write (a[i],' ');   
end;    
procedure sort (var a : mas; l : integer);   // перевернуть массив 
// т.е 1234 -> 4321    
var     i,buf : integer;   
begin   
for i := 1 to l div 2 do     
begin     
buf := a[l-i+1];     
a[l-i+1] := a[i];     
a[i] := buf;     
end;   
end;  

begin 
a := re(); 
l := C(m,a); 
sort (m,l); 
wr (m,l); 
end.

на примере числа
 125
после выполнения функции C
m[1] = 5 m[2] =2 m[3] =1
после выполнения процедуры Sort
m[1] =1 m[2] =2 m[3] =5
Вывод на экран элементов массива через пробел
1 2 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?