В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Liya20034
Liya20034
20.03.2021 14:50 •  Информатика

Составить программу в с++, печатающую значение true , если указанное высказывание является истинным , и false в противном случае : числа a и b выражают длины катетов одного прямоугольного треугольника , а c и d - другого . эти треугольники являются подобными . на языке с ++

Ответ:
vankovvandam
vankovvandam
20.07.2020 18:51
#include <iostream>
using namespace std;

int main()
{
    double a,b,c,d;
    cout << "Enter 1st-triangle catheti here: " << endl;
    cin >> a >> b;
    cout << "Enter 2nd-triangle catheti here: " << endl;
    cin >> c >> d;

    bool podobie = ((a/c == b/d) || (a/d == b/c));

    cout << boolalpha;
    cout << podobie;
    
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?