В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ikonnikoval
ikonnikoval
27.02.2020 20:31 •  Информатика

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).

Ответ:
дашулька223
дашулька223
20.07.2020 17:10
Var a, b, c: integer;
begin
write('Введите углы a, b, c >> ');
readln(a, b, c);
if a+b+c = 180 then
if (a>0) and (b>0) and (c>0) then
begin
if (a=b) and (b=c) then writeln('Равносторонний ');
if ((a=b) and (a<>c)) or ((b=c) and (b<>a)) or ((a=c) and (c<>b)) then writeln('Равнобедренный ');
if (a<>b) and (b<>c) and (a<>c) then writeln('Разносторонний ');
if (a=90) or (b=90) or (c=90) then writeln('Прямоугольный ');
if (a>90) or (b>90) or (c>90) then writeln('Тупоугольный ');
if (a<=89) and (b<=89) and (c<=89) then writeln('Остроугольный ')
end
else
writeln('Углы должны быть больше 0')
else
writeln('Сумма углов не равна 180 градусам');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?