В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
даша2336
даша2336
28.12.2020 06:12 •  Информатика

Склавиатуры вводится строка символов. составить программу , которая находит номер первого и последнего символа 'к' и заменяет все символы между этими буквами на звездочку . сделать алгоритм и программу

Ответ:
ilqartural2005
ilqartural2005
20.07.2020 16:21
program zwezda;
uses Crt;
var S: string;
     i, Len: integer ;

begin
ClrScr;
  Write('Ввод строки: '); ReadLn(S);
  ClrScr;
  WriteLn ('‘Строка:  ', S);
  WriteLn;
  WriteLn ('Первый символ: ', S[1]);
  Writeln;
  Len:=length(S);
  WriteLn('Посдедний символ: ',S[Len]);
  WriteLn;
  for i:=2 to len -1 do
     S[i]:='*';
  WriteLn('Результат:  ',s);
  ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?