Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
gladchenko77
19.05.2020 21:49 •
Информатика
Впаскале составить прогу.если можно на уровне 9го класса составить программу для вычисления значения функции на отрезке [a,b] с шагом 1.
Ответ:
DanilBeast
02.10.2020 11:00
Мы взяли функцию f(x) = sin(x)-2*cos(x).
В процедуру-функцию function можно вставлять любые функции
program func;
uses Crt;
var a, b, x, y:real;
function f(var x:real):real;
begin
f:=sin(x)-2*cos(x);
end;
begin
ClrScr; {Очистка экрана}
Write (' a= '); ReadLn(a);
Write (' b= '); ReadLn(b);
WriteLn;
x:=a;
while x<=b do
begin
y:=f(x);
WriteLn ('y(', x:1:0, ')= ', y:4:2);
x:=x+1;
end;
ReadLn;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ХристинаРоманівна
21.11.2021 15:36
Назовите правила преобразования информации...
prostoliii
02.09.2022 10:21
Объясните как делать или кто похожее делал??...
Kruzhilina242003
30.11.2021 09:55
дорешать задачу по информатикеНатуральные числа a, b, c, называются числами Пифагора, если выполняется условие a^2+b^2=c^2. Напечатать все числа Пифагора меньшие ребзи...
Никитар456
21.03.2023 10:22
1)Многим электронным устройствам, в том числе и андроидам, для подзарядки нужен ... (11 букв)2)По этому проводу передается и электричество и информация (6 букв) если что...
наруоклоктлалтмтата
20.03.2021 06:27
Каков результат выполнения алгоритма при: Х=8?...
DARKFEST1
08.12.2020 06:48
Какие действия выполняются над высказываниями ...
Dimoon122
07.07.2020 02:32
Производится двухканальная(стерео) цифровая звукозапись. Значение сигнала фиксируется в 48000 раз в секунду, для записи каждого значения используется 32 бит. Запись длится...
antipingv2004
12.03.2022 13:56
Значение птиц в жизни ! положительные и отрицательные!...
alyaagafonova
05.10.2020 15:47
Укого и как хлестаков брал взаймы? 20...
nyrlan13531
02.03.2020 14:42
Знаменитые люди алтайского края...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
В процедуру-функцию function можно вставлять любые функции
program func;
uses Crt;
var a, b, x, y:real;
function f(var x:real):real;
begin
f:=sin(x)-2*cos(x);
end;
begin
ClrScr; {Очистка экрана}
Write (' a= '); ReadLn(a);
Write (' b= '); ReadLn(b);
WriteLn;
x:=a;
while x<=b do
begin
y:=f(x);
WriteLn ('y(', x:1:0, ')= ', y:4:2);
x:=x+1;
end;
ReadLn;
end.