В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ninacat1
ninacat1
26.05.2023 17:34 •  Информатика

Написать программу в паскале дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.

Ответ:
mailnadejda
mailnadejda
20.07.2020 15:12

program n_1;

var m,n,n1,n2,n3,n4:integer;

begin

 writeln('Введите трехзначное натуральное число: ');

 readln(n);

 n1:=n mod 10;

 n2:=(n mod 100) div 10;

 n3:=n div 100;

 m:=n1+n2+n3;

 writeln('Сумма цифр: ',m);

 writeln('Среднее арифметическое: ',m/3:0:5);

 m:=100*n1+10*n2+n3;

 writeln('В обратном порядке: ',m)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?