В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

1.составьте программу вывода матрицы: 1 1 1 1 2 2 2 2 3 3 3 3 2.составьте программу вывода матрицы: 1 2 3 4 1 2 3 4 1 2 3 4

Ответ:
astakastaj
astakastaj
02.10.2020 10:52
{Задача 1}
type Mat = arrsay [1..3, 1..4] of integer;
var i: integer;
A: Mas;
begin
for i:=1 to 3 do
   begin
     for j:=1 to 4 do
         Write (i:4);
    WriteLn;
  end;
ReadLn;
end.

{Задача 2}
type Mat = arrsay [1..3, 1..4] of integer;
var i:integer;
A: Mas;
begin
for i:=1 to 3 do
   begin
     for j:=1 to 4 do
         Write (j:4);
    WriteLn;
  end;
ReadLn;
end.
0,0(0 оценок)
Ответ:
мирэлюзий
мирэлюзий
02.10.2020 10:52
Var
  i,j:integer;
begin
  for i:=1 to 3 do
  begin for j:=1 to 4 do Write(i:2); Writeln end
end.

Результат выполнения программы:
 1 1 1 1
 2 2 2 2
 3 3 3 3

var
  i,j:integer;
begin
  for i:=1 to 3 do
  begin for j:=1 to 4 do Write(j:2); Writeln end
end.

Результат выполнения программы:
 1 2 3 4
 1 2 3 4
 1 2 3 4

Программы отличаются ровно одним символом - именем переменной в обращении к процедуре вывода: Write(i:2); и Write(j:2);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?