В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кирилл2434
кирилл2434
19.11.2022 18:25 •  Информатика

Решить 20 ! дано целое число n (0< =n< =9). написать программу, вычисляющую сумму всех двузначных чисел(в записи которых нет цифры n) даны целые числа a и b.написать программу, подсчитывающую сумму двузначных чисел, у которых либо первая цифра равна a, либо вторая цифра равна b. написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу n все через while

Ответ:
Вкорма
Вкорма
02.10.2020 10:47
Program tak;
var a,b,c,N:integer;
begin writeln('введите число N (0<=N<=9) ');
 readln(N);
 b:=0; 
for a:=99 downto 10 do  begin 
  if (N <> a div 10) and (N <> a div 10) then 
  b:=a+b; 
 end;
 writeln(b);
end.
эт первая

program tak2;
var a,b,c,d:integer;
begin writeln('введите два числа ');
 readln(a,b);
 d:=0; 
for c:=99 downto 10 do  begin 
  if (a = c div 10) or (b = c mod 10) then 
  d:=c+d;
  end;
 writeln(d);
end.
эт вторая
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?