В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olegtoda
olegtoda
07.06.2021 16:55 •  Информатика

Составьте программу произведения первой и третьей и суммы второй и четвертой цифры четырехзначного числа (паскаль)

Ответ:
школьник814
школьник814
20.07.2020 12:53
Program zadacha;
var
a,p,s:integer;
begin
writeln('Введите четырехзначное число');
readln(a);
p:=(a div 1000)*(a mod 100 div 10);
s:=(a div 100 mod 10)+(a mod 10);
writeln('Произведение первой и третьей =',p);
writeln('Сумма второй и четвертой = ',s)
end.
0,0(0 оценок)
Ответ:
ilinet
ilinet
20.07.2020 12:53
Program programma;
var a,b,c,d,e,p,s: integer;
begin
writeln ('Введите четырехзначное число');
readln (a);
b:=a div 1000;
c:=a div 100;
c:=c mod 10;
d:=a mod 100;
d:=d div 10;
e:=a mod 10;
p:=b*d;
s:=c+e;
writeln ('Произведение первой и третьей цифры равно ',p,', сумма второй и четвертой цифры равна ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?