В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу, которая осуществляет вывод одномерного массива, поиск максимального значения и выводит его индекс в этом массиве.

Ответ:
дэвттвс
дэвттвс
20.07.2020 09:52
Var i,imax,amax:integer;
a:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do
begin
write('a[',i,']= ');
read(a[i]);
end;
a[1]:=amax;
imax:=1;
for i:=1 to 10 do
if amax<a[i] then
begin
amax:=a[i];
imax:=i;
end;
writeln('Исходный массив');
for i:=1 to 10 do
write(a[i]:4);
writeln;
writeln('Элемент под номером ',imax,' имеет максимальное значение равное ',amax);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?