В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Murzikov
Murzikov
21.11.2022 16:02 •  Информатика

умоляю! составить программу на языке програмирования паскаль. 1) пойдет ли сундук с соровищами со сторонами а,в,с в иллюминатор затонувшего корабля диаметром д. 2) имеется треугольник с координатами(0,0)(5,0)(0,5). попадает ли точка а(х,у) внутрь либо на границы этого треугольника. ответ вывести в форме да или нет.

Ответ:
123qwerty0
123qwerty0
20.07.2020 08:04
Var
  a,b,c,d,x,y:real;
begin
  Write('Введите размеры сторон сундука -> '); Readln(a,b,c);
  Write('Введите диаметр иллюминатора -> '); Readln(d);
  if a<b then begin
    x:=a;
    if b<c then y:=b else y:=c
  end
  else begin
    x:=b;
    if a<c then y:=a else y:=c
  end;
  if (sqr(x)+sqr(y)<sqr(d)) then Writeln('Сундук можно вытащить')
  else Writeln('Сундук нельзя вытащить')
end.

Тестовое решение:
Введите размеры сторон сундука -> 3 5 3.99
Введите диаметр иллюминатора -> 5
Сундук можно вытащить

**********************
Условие попадания точки A(x,y) внутрь треугольника описывается как
\begin {cases} x\ge 0 \\ y\ge 0 \\ y\le 5-x \end {cases} \Rightarrow \ (x\ge0) \land (y\ge0) \land (y\le 5-x)

var
  x,y:real;
begin
  Write('Введите координаты x и y точки -> '); Readln(x,y);
  if (x>=0) and (y>=0) and (y<=5-x) then Writeln('Да')
  else Writeln('Нет')
end.

Тестовое решение:
Введите координаты x и y точки -> 3 2.5
Нет

Введите координаты x и y точки -> 2.1 2.8
Да
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?