В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nasya156
Nasya156
18.01.2022 15:22 •  Информатика

Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата

Ответ:
hzhwhsbsh
hzhwhsbsh
20.07.2020 07:54
Var
  a,r,rvp,rop:real;
begin
  Write('Введите сторону квадрата и радиус окружности: ');
  Readln(a,r);
  rvp:=a/2; rop:=a*sqrt(2)/2;
  if r<rvp then Writeln('Окружность расположена внутри вписанной')
  else
    if r=rvp then Writeln('Введен радиус вписанной окружности')
    else
      if r<rop then Writeln('Окружность расположена между вписанной и описанной')
      else
        if r=rop then Writeln('Введен радиус описанной окружности')
        else Writeln('Окружность расположена вне описанной')
end.

Тестовое решение:
Введите сторону квадрата и радиус окружности: 8 5
Окружность расположена между вписанной и описанной
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?