В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
анабель125
анабель125
01.12.2022 18:30 •  Информатика

Составить программу на языке паскаль. просто ! умоляю! 1)составить программу ввода букв или цифры,или спецзнака. выводить сообщение типа"это "," это буква..",или "это спецзнак..". к сообщению добавлять саму цифру,букву,спецзнак. 2)у белых на доске остался король,а у черных король и ферзь. охарактеризовать положение белых с одного из слов шах,мат,пат,обыкновенная позиция

Ответ:
lglglglgl
lglglglgl
02.10.2020 10:21
Задача 1, Pascal.ABC.Net

const
  sAlpha='';
  sDigit='0123456789';
var
  c,c1:char;
begin
  Write('Введите символ: '); Readln(c);
  c1:=LowerCase(c);
  if Pos(c1,sAlpha)>0 then Writeln('Введена буква ',c)
  else
    if Pos(c1,sDigit)>0 then Writeln('Введена цифра ',c)
    else Writeln('Введен спецсимвол ',c)
end.

Программирование задачи №2 - большая работа, требующая многих часов, если не имеется готовых наработок для программирования шахматной игры. Давать подобные задачи для решения на данном Сервисе - бесполезное занятие, такое не задают даже на олимпиадах.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?