В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу вычисления n! =1*2*3**n

Ответ:
Tcgdfh
Tcgdfh
20.07.2020 01:16
Program X;

var
k,n,i,j:longint;
mas:array[1..10000] of longint; 

begin

read(n);

for i:=1 to 10000 do 
   mas[i]:=0; 

mas[10000]:=1;

for j:=1 to n do 
   begin
    for i:=1 to 10000 do
      mas[i]:=mas[i]*j; 
    for i:=10000 downto 2 do
      begin   
      mas[i-1]:=mas[i-1]+mas[i]div 10;
      mas[i]:=mas[i]mod 10;
      end;
   end;

i:=1;

while mas[i]=0 do 
     i:=i+1;
for j:=i to 10000 do
    write(mas[j]) 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?