В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tylerxjosh
tylerxjosh
16.12.2022 03:23 •  Информатика

Напишите программу для решения следующей в qbasic девятиклассники участвовали в викторине по . необходимо было ответить на 20 вопросов. победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. на сколько вопросов победитель ответил правильно? если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите yes, иначе выведите no. гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов. программа получает на вход число участников викторины n (1 ≤ n ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ. пример работы программы: входные данные 4 15 12 0 17 выходные данные 17 yes

Ответ:
magomed200495
magomed200495
19.07.2020 22:58
var
    i, k,n, max: integer;
    f:boolean;
begin
    readln(k);
    for i := 1 to k do
    begin
        readln(n);
        if (i = 1) or (max < n) then
            max := n;
        f:=f or (n=0);
    end;
    writeln(max,' ', f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?