В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
red011
red011
17.05.2023 08:02 •  Информатика

Написать программу: в массиве из 10 вводимых с клавиатуры чисел подсчитать количество чисел кратных первому элементу, но не кратных последнему элементу.  ​

Ответ:
zabirovrobert
zabirovrobert
26.05.2020 00:01

var

   numbers: Array[1..10] of Integer;

   i, first, last, count, num: Integer;

begin

   writeln('Введите 10 чисел');

   

   for i := 1 to 10 do

       readln(numbers[i]);

   first := numbers[1];

   last := numbers[10];

   

   for i := 1 to 10 do begin

       num := numbers[i];

       

       if (num >= first) and (num mod first = 0) then

           if (num < last) or (num mod last <> 0) then

               count := count + 1;

   end;

   

   writeln(count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?