В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Polhova1606
Polhova1606
16.10.2022 14:14 •  Информатика

Дан массив e(10). составить программу обработки массива: 1. положительные элементы массива заменить нулями. 2. определить число элементов массива равных 5. 3. найти сумму чисел, неравных 3. все это должно быть в одной , решите качественно, много . ах, да, все это на языке паскаль.

Ответ:
389648
389648
19.07.2020 19:59
var sum,c,i,l:integer;
E:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do begin
read(e[i]);
if e[i]>0 then e[i]:=0;
if e[i]=5 then l:=l+1;
if e[i]<> 3 then sum:=sum+e[i];
end;
writeln('Полученный массив');
for i:=1 to 10 do
write(e[i]:4);
writeln;
writeln('Сумма чисел, не равных трем равна ',sum);
writeln('Число элементов массива, равных пяти равна ',l);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?