В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
molokomo
molokomo
30.12.2021 07:56 •  Информатика

Написать программу: даны длины сторон треугольника a,b,c. является ли он прямоугольным?

Ответ:
dashasokolova21
dashasokolova21
19.07.2020 19:28
Var a,b,c,t:real;
begin
readln(a,b,c);
if b>a then begin
  t:=a;
  a:=b;
  b:=t;
end;
if c>a then begin
  t:=a;
  a:=c;
  c:=t;
end;
if (a*a=b*b+c*c) then writeln('Треугольник прямоугольный') else writeln('Треугольник не прямоугольный');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?