В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Нужно написать программу.введите с клавиатуры 2 числа а и в,если числа не равны,то замените каждое из них на 0 и выведите результатом на экран.если они равны,то найдите и выведите удвоенную сумму этих чисел

Ответ:
kotovad444
kotovad444
25.05.2020 23:18

var a,b:integer;

begin

readln(a,b);

if a<>b then begin a:=0; b:=0; writeln(a,' ',b); end else writeln(2*(a+b));

end.

0,0(0 оценок)
Ответ:
manyaovakimyan
manyaovakimyan
25.05.2020 23:18

var
  a, b: real;  //Инициализируем 2 действительных переменных

begin
  writeln('Введите 2 числа');
  readln(a, b);  //Вводим 2 числа
  if a <> b then   {Если числа не равны, то присваиваем переменным нули и печатаем их, иначе печатаем удвоенную сумму этих чисел}
  begin
    a:= 0;
    b:= 0;
    writeln('a = ', a, ', b = ', b);
  end
  else writeln('2 * (', a, ' + ', b, ') = ', 2 * (a + b));
end.

Если все правильно, отметь решение как лучшее)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?