В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sychev66
sychev66
15.08.2020 10:27 •  Информатика

Написать программу которая принимает с клавиатуры 5-значное число а выводит сумму цифр этого числа !

Ответ:
luzhtzkayanasty
luzhtzkayanasty
02.10.2020 09:16
Program chisla;
uses crt;
var a,b,c,d,e,f,summa : integer;
begin
write('Введите пятизначное число ');
Readln(a);
if (a>99999) or (a<10000) then Writeln('Введено не пятизначное число')
else
begin
b:=a div 10000;
c:=(a-(b*10000)) div 1000;
d:=(a-(b*10000)-(c*1000)) div 100;
e:=(a-(b*10000)-(c*1000)-(d*100)) div 10;
f:=a-(b*10000)-(c*1000)-(d*100)-(e*10);summa:=b+c+d+e+f;
Writeln(summa);
end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?