В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
saneok67p086je
saneok67p086je
31.03.2020 23:05 •  Информатика

(30 ! ): составить программу на языке паскаль для решения следующей : задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30; 40]; найти количество элементов массива, принадлежащих промежутку [-10; 25).

Ответ:
Ьрнрг
Ьрнрг
02.10.2020 09:16
Const
    n = 3;
var
  i,s:integer;
  a:array[1..n] of integer;
begin
  s:=0;
  for i:=1 to n do
   begin
     a[i]:=random(71)-30;
     if (a[i]>=-10) and (a[i]<25) then s:=s+1;
   end;
  writeln('Полученный массив:');
  for i:=1 to n do
   write('a[':4,i,']=',a[i]);
  writeln;
 write('Промежутку [-10;25) принадлежат ',s,' элемент(ов)');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?