В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Выполнить это по информатике: составить программу на языке паскаль для решения следующей : задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30; 20] и найти наименьший элемент среди положительных элементов (учесть вариант, когда в массиве может не оказаться положительных элементов учесть правильность написания самой программы (чтобы можно было вставить в паскаль и не исправлять чужие ошибки.(я ещё в своих не разбираюсь))

Ответ:
Liz1ka
Liz1ka
19.07.2020 10:58
Const
    n = 3;
var
  i,b:integer;
  a:array[1..n] of integer;
begin
  b:=21;
  for i:=1 to n do
   begin
     a[i]:=random(51)-30;
     if (a[i]>0) and (a[i]<b) then b:=a[i];
   end;
  writeln('Полученный массив:');
  for i:=1 to n do
   write('a[':4,i,']=',a[i]);
  writeln;
 if b<21 then write('Наименьший элемент = ',b) else write('Нет положительных элементов')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?