Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Kaishuudee
05.11.2021 23:18 •
Информатика
Написать алгоритм факториала в паскале
Ответ:
ггвв
19.07.2020 10:06
Var
i, n: integer;
f: longint;
begin
Write('Задайте натуральное число: ');Readln(n);
f := 1;
for i := 2 to n do f := f * i;
Writeln(n, '!=', f)
end.
Тестовое решение:
Задайте натуральное число: 5
5!=120
0,0
(0 оценок)
Популярные вопросы: Информатика
Nastyha1741
02.03.2023 09:28
Действия робота зависят от датчика. Робот держит дистанцию в см. от препятствия. Для того что бы программный блок «Переключатель» выполнялся многократно, его поместили внутрь...
milerowskaya
17.04.2023 10:21
Сделайте код для этого задания ыныорматика 8клас графично...
Diana2004250
11.12.2022 00:24
1. Постройте блок- схему по заданному условию 2. Запишите код программы с условного оператора х=5 у= -6 если (х у) то z=x+y иначе z=y-x вывод (z)...
nilnazarov666
18.05.2023 06:07
Задание 1. Составьте программу, которая вычисляет значение выражения Задание 2. Составьте программу, которая вычисляет количество секунд в заданном количестве часов по формуле с...
Egorpiernand
21.03.2022 15:48
Как с анимации можно перемещать изображение в указанном направлении...
Цветочек123огрл
27.11.2020 19:59
Найди Ключевые слова по теме и, используя их, составъ предложения.12345АAПРс3B IIEВДнСй я иTБDJIKоц Ф1 А2, А3, В2, A5, B2, B5, C4, А1, D4, C3, С2.2 В1, А1, C5, D1, D3, B5.3.А4,...
Muhammadkhodja
10.03.2022 01:30
1) Какие операционные системы вы знаете? 2) Каким образом запустить программу на выполнение? 3) Зачем нужна операционная система? 4) Приведите пример трёх прикладных программ и...
незнайка1187
06.08.2021 15:39
Определите результат выполнения программы, при x=0, a=-8...
ifraank
02.05.2021 13:06
Составить программу для определения является ли человек молодым (от 0 до 25 лет), зрелым ( от 26 до 60 лет) или пожилым (с 61 года). * Мой ответ...
Uqqt
04.05.2023 11:15
Информатика Сколько цветов распознает датчик цвета? Как робот движется по линии Зачем нужен датчик цвета?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i, n: integer;
f: longint;
begin
Write('Задайте натуральное число: ');Readln(n);
f := 1;
for i := 2 to n do f := f * i;
Writeln(n, '!=', f)
end.
Тестовое решение:
Задайте натуральное число: 5
5!=120