В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
настя7603
настя7603
05.04.2020 03:24 •  Информатика

1)составить программу для нахождения суммы первых n натуральных чисел.(n вводим с клавиатуры). 2) написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел в порядке убывания. большое ! )

Ответ:
Kseniaa26
Kseniaa26
02.10.2020 09:12
Var
  s, n: integer;

begin
  Write('Введите натуральное число: '); Readln(n);
  s := ((n + 1) * n) div 2; { сумма арифметической прогрессии }
  Writeln('Сумма натуральных чисел от 1 до ', n, ' равна ', s)
end.

Результат выполнения программы:
Введите натуральное число: 10
Сумма натуральных чисел от 1 до 10 равна 55

var
  i: integer;

begin
  Writeln('Квадраты первых пяти нечетных натуральных чисел');
  i := 5 * 2 - 1;
  while i > 0 do begin Writeln(i:2, sqr(i):5); i := i - 2 end
end.

Результат выполнения программы:
Квадраты первых пяти нечетных натуральных чисел
 9   81
 7   49
 5   25
 3    9
 1    1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?