В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
18.03.2021 07:28 •  Информатика

Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до -15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа, кратные 6 уменьшает в 2 раза, а у остальных элементов находит целое от деления на 5 4) меняет местами значения третьего и 11 элементов на экран вывести исходный и преобразованный массив с поясняющим текстом

Ответ:
grigorisinnatal
grigorisinnatal
25.05.2020 22:45

var a:array[1..15]of integer;
i:integer;
begin
for i:=1 to 15 do begin a[i]:=random(31)-15; write(a[i]:4); end;
writeln;
for i:=1 to 15 do if a[i]>=0 then a[i]:=sqr(a[i]) else a[i]:=abs(a[i]);
for i:=1 to 15 do write(a[i]:4);
end.

 

var a:array[1..15]of integer;

i:integer;

begin

for i:=1 to 15 do begin a[i]:=random(31)-15; write(a[i]:3); end;

writeln;

for i:=1 to 15 do if a[i] mod 2=0 then a[i]:=2 else a[i]:=a[i]-5;

for i:=1 to 15 do write(a[i]:3);

end.

 

var a:array[1..15]of integer;

i:integer;

begin

for i:=1 to 15 do begin a[i]:=random(31)-15; write(a[i]:3); end;

writeln;

for i:=1 to 15 do if a[i] mod 6=0 then a[i]:=a[i] div 2 else a[i]:=a[i] div 5;

for i:=1 to 15 do write(a[i]:3);

end.

 

 

var a:array[1..15]of integer;

i,k:integer;

begin

for i:=1 to 15 do begin a[i]:=random(31)-15; write(a[i]:3); end;

writeln;

k:=a[3];

a[3]:=a[11];

a[11]:=k;

for i:=1 to 15 do write(a[i]:3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?