В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу для вычисления значения выражения x в степени n + y в степени m. значения x,y,n,m > 0 вводятся с клавиатуры. примечание: чтобы возвести число в n-ную степень, надо его умножить само на себя n раз.

Ответ:
Хурем
Хурем
19.07.2020 09:00
Begin
var x, y, n, m: integer;
Readln(x, y, n, m);
Assert((x > 0) and (y > 0) and (n > 0) and (m > 0));
var upstep: integer := n + y;
for var i := 2 to m do
upstep *= (n + y);
var lowstep := x;
for var j := 2 to upstep do
lowstep *= x;
Writeln(lowstep);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?