В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
melchenko11
melchenko11
17.08.2020 17:41 •  Информатика

Написать алгоритм для паскаля. составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.

Ответ:
kokosik23
kokosik23
19.07.2020 07:24
//Составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.

begin
var a := ReadInteger;
var c : string;
Assert(a >= 1);
Assert(a <= 99);
case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: c := 'Копейка';
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: c := 'Копейки';
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..100: c := 'Копеек';
end;
Writeln(a, ' ', c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?