В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Galerina
Galerina
03.06.2023 09:43 •  Информатика

Составьте программу, которая : в строке "я учусь в школе" заменяет слово "в школе" на " в 10-м классе".

Ответ:
ульянка37
ульянка37
25.05.2020 22:40

Program 1;
Uses CRT;
Var
s: String;
Begin
Writeln('Введите фразу');
read(s);
if (s='Я учусь в школе') then
writeln ('Я учусь в 10-м классе')
end.

0,0(0 оценок)
Ответ:
User5281
User5281
25.05.2020 22:40

var
  s: string;

begin
  s:= 'Я учусь в школе';  //Присваиваем начальное значение строковой переменной
  writeln(s);  //Печатаем начальное значение
  Delete(s, 11, 5);  {Удаляем из строки s, начиная с 11 позиции 5 символов (т.е. удаляем слово школа)}
  Insert('10-м классе', s, 11);  {Вставляем строку '10-м классе' в строку s, начиная с 11 позиции}
  writeln(s);  //Печатаем получившуюся строку
end.

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?