В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shaxnozatosheva
shaxnozatosheva
06.01.2021 10:39 •  Информатика

Вычислить сумму натуральных чисел от 1 до n . составить программу нахождения кол-ва делителей числа n ( значение n вводится с клавиатуры )

Ответ:
дэнчик626
дэнчик626
19.07.2020 06:58
Держи!
1)
var i,n,result:integer;
begin
read(n);
result:=0;
for i:=1 to n do
begin
   result:=result+i;
end;
write(result);
end.

2)
var i,n,increase,result:integer;
massive = array[1..1000] of integer;// ищем делители в диапазоне 1-1000
begin
read(n);
for i:=1 to 1000 do
begin
   if((n mod massive[i])=0) then
   begin
       increase:=increase + 1;
   end;
end;
result:=increase;
write(result);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?