В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vladosik0987
Vladosik0987
07.11.2022 08:58 •  Информатика

Написать программу на языке паскаль) в прямоугольник со сторонами a и b вписан круг. найти длину окружности.

Ответ:
МахаХей
МахаХей
02.10.2020 09:03
Если ты имел ввиду описанную около пр-ка окружность то вот

program dlinap;
uses crt;
var a,b,diam,dlina : real;
const pi=3.14;
begin
write('Чему равна длина и ширина пр-ка?');
Readln(a,b);
diam:=sqrt(sqr(a)+sqr(b));
dlina:=pi*diam;
Writeln('Длина окружности равна ',dlina);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?