В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alyakozlova22
alyakozlova22
01.12.2020 00:27 •  Информатика

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное. была написана следующая программа: var a, b: integer; begin readln(a, b); a : = a mod 2; if a > 0 then b : = b mod 2; if b > 0 then writeln ('четных чисел нет') else writeln ('четное число есть'); end. известно, что программа написана с ошибками. последовательно выполните три : укажите, как, по вашему мнению, нужно доработать программу (не используя слож-ные условия), чтобы не было случаев ее неправильной работы;

Ответ:
SachaNabok
SachaNabok
02.10.2020 08:47
Var
a,b:integer;
Begin
readln(a,b);
if a mod 2= 0 then writeln('есть чётное')
else if b mod 2=0 then writeln('есть чётное') 
else writeln('Нет чётных);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?