В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Акося3557
Акося3557
23.03.2022 01:51 •  Информатика

Напишите программу на языке паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный. если они прямоугольные, то должно выводится сообщение 'это прямоугольный треугольник'.

Ответ:
Матвей2048602
Матвей2048602
02.10.2020 08:40
Var a,b,c:real;
begin
read(a, b, c);
if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(bthen
write('Это прямоугольный треугольник')
else
write('Это не прямоугольный треугольник')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?