В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nik180208mailru
nik180208mailru
20.03.2020 09:30 •  Информатика

Решить в паскале с использованием цикла с ! числа фибоначчи (fn) определяются формулами: f0=f1=1; fn=fn-1+fn-2 при n=2, составить программу: а) определения f - 40-е число фибоначчи; б) поиска f - первого числа фибоначчи, большего m (m> 1); в) вычисления s - суммы всех чисел фибоначчи, которые не превосходят 1000

Ответ:
отво
отво
25.05.2020 21:56

// A)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var Count := 2;

 

 repeat

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

   Count += 1

 until Count = 40;

 

 Write(f2)

end.

// B)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var m := ReadlnInteger();

 

 repeat

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

 until f2 > m;

 

 Write(f2)

end.

// C)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var S := f1;

 

 repeat

   S += f2;

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

 until f2 >= 1000;

 

 Write(S)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?