В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
annayotubeanna
annayotubeanna
24.12.2022 07:16 •  Информатика

Напишите программу , которая вводит число n и определяет является ли число n совершенным. совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу

Ответ:
kirillfox99ozbdp8
kirillfox99ozbdp8
17.07.2020 17:36
Var n, i, s:integer;
begin
read(n);
s:=0;
for i:=1 to n-1 do begin
   if n mod i = 0 then s:=s+i;
end;
if s = n then writeln('sovershennoye') else writeln('ne sovershennoye');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?