В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
voVIK2008
voVIK2008
17.04.2020 12:08 •  Информатика

Даны коэффициенты квадратного уравнения a,b,c.напишите программу которая решает это квадратное уравнение.(в паскале)

Ответ:
wewewewwe
wewewewwe
17.07.2020 16:55
Program Uravnenie;
uses Crt;
var a,b,c,x,x1,x2 : real ;
begin     
clrscr;
     writeln ( 'Введите a : ' );
     readln ( a );
     writeln ( 'Введите b : ' );
     readln ( b );
     writeln ( 'Введите c : ');
     readln ( c );
     if ( sqr ( b ) - 4 * a * c ) < 0
               then  writeln ( ' Уравнение не имеет решения ' )                                   else begin                         
if ( sqr ( b ) - 4 * a * c ) = 0 
                        then begin
                                   x:= - b / ( 2 * a );
                                   writeln( ' x = ', x : 8 : 2 )
                              end                         
else
 begin                                 
      x1:= ( - b + sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
      x2:= ( - b - sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
      writeln( ' x1 = ', x1 : 8 : 2, ' x2 = ', x2 : 8 : 2 ) 
end
end.
0,0(0 оценок)
Ответ:
ГАТИНЫ
ГАТИНЫ
17.07.2020 16:55
Program s;
var a,b,c,x,z,d:real;
begin
write('Введите a,b,c');
read(a,b,c);
d:=(b*b)-(4*a*c);
if d<0 then write(' Уравнение не имеет корней')
else
x:=(-b+sqrt(d))/(2*a);
z:=(-b-sqrt(d))/(2*a);
write(' х равно ',x, ', ', z);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?