В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
elena444454
elena444454
14.07.2020 23:24 •  Информатика

Составить программу нахождения корней квадратного уравнения если a=3 b=34 c=4b и выводящую ответ на экран

Ответ:
BaRiGaSimon
BaRiGaSimon
17.07.2020 16:07
Мой код на Java прикреплен, 427 строк где-то (907 в оригинале)
вот код на паскале для твоей задачи
var a,b,c,d:integer;
x1,x2:real;
begin
readln(a,b,c);
d:=(b*b) - (4*a*c); writeln(d);
if d < 0 then writeln('корней нет');
if d = 0 then begin writeln('один корень'); x1:=-b/(2*a); writeln(x1:0:3); end;
if d > 0 then begin writeln('два корня'); x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a); writeln(x1:0:3,x2:0:3); end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?