В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ALINAscool9898
ALINAscool9898
04.04.2021 10:46 •  Информатика

Составить программу рисования ромашки на паскале.

Ответ:
Neronkilir228
Neronkilir228
25.05.2020 21:49

Вот программа, довольно понятная, 

комментарии:

lepestkov:=13; - тут можно менять количесто лепестков

fi:=2*3.14*i/lepestkov;

2*Pi - это полный угол 360 градусов. мы делим его на количество лепестков. Таким образом мы получаем угол на который должен идти лепесток.

 

Картинка ромашки во вложении. если такая не пойдет, отмечай как нарушение.

 

uses crt, graph;
var gDriver, gMode, errCode:integer;
i:integer;
lepestkov:integer;
fi,x,y:real;
radius:integer;
begin
gDriver:=Detect;
InitGraph(gDriver, gMode,'');
ErrCode:=GraphResult;
if(GraphResult <> grOK) then
begin
writeln('ne mogu naiti file graphiki');
readln;
end;
setcolor(green);
line(320,200,320,400);
setcolor(yellow);
setFillStyle(SolidFill, yellow);
fillellipse(320,200,15,15);
setFillStyle(SolidFill, white);
setcolor(white);
lepestkov:=13;
for i:=1 to lepestkov do
begin
fi:=2*3.14*i/lepestkov;
for radius:=24 to 60 do
begin
x:=320 + radius*cos(fi);
y:=200 + radius*sin(fi);
fillellipse(round(x),round(y),10,10);
end;
end;
readln;
end.


Составить программу рисования ромашки на паскале.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?