В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
liliyana27
liliyana27
27.07.2021 18:24 •  Информатика

Составить программу для нахождения площади ромба по стороне а и острому углу f (угол предварительно переведите в радианы t = f · 3,14 : 180) по формуле s = a 2 sin t

Ответ:
DimazCheat
DimazCheat
17.07.2020 11:51
Var
  a, f, t, S: real;

begin
  Write('Введите длину стороны ромба: '); Readln(a);
  Write('Введите величину острого угла ромба в градусах: '); Readln(f);
  t := f * pi / 180;
  S := sqr(a) * sin(t);
  Writeln('Площадь ромба равна ', S, ' кв.ед.')
end.

Тестовое решение:
Введите длину стороны ромба: 14.3
Введите величину острого угла ромба в градусах: 58.7
Площадь ромба равна 174.728286173858 кв.ед.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?