В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
den1112pro
den1112pro
19.02.2020 20:24 •  Информатика

1. нужно составить программу на языке программирования (язык программирования и версию необходимо обязательно указать, иначе количество за будет равно 0) : календарь жителей планеты мульти состоит из n месяцев, каждый месяц состоит ровно из 30 дней, неделя состоит из 7 дней. особо несчастливыми на планете мульти считается 13-е число месяца, если оно выпадает на пятницу. известно, что новый год на планете мульти начался в k-й по счету день недели (1-й день недели — понедельник, 2-й — вторник, 3-й — среда, … , 7-й — воскресенье). определите, сколько в этом году на планете мульти будет особо несчастливых пятниц, 13-е. программа получает на вход два натуральных числа, записанных в отдельных строках. первое число — количество месяцев в календаре планеты мульти n, не превосходящее 109. второе число — номер дня недели, на который приходится первое число первого месяца нового года, может принимать значения от 1 до 7. программа должна вывести единственное натуральное число — количество несчастливых дней в этом году. пример входных и выходных данных ввод вывод примечание 12 1 2 2 на 13-е число будут приходиться пятницы четверого и одиннадцатого месяцев.

Ответ:
Shmanin32
Shmanin32
02.10.2020 07:54
Язык программирования Pascal ABC
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then
begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then
begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?