В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
azalinasabirova
azalinasabirova
01.02.2023 09:25 •  Информатика

Напишите программу , которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b < = 36.

Ответ:
543421
543421
17.07.2020 06:45
Var i,k,j,n,ost,p:integer;   
x,s:string;
begin 
  read(s); 
  n:=strtoint(s); 
  for j:=11 to 36 do   
  begin     
    x:='';     
    p:=n;     
    k:=0;     
    while p<>0 do       
    begin         
      ost:=p - (p div j)*j;         
      p:=p div j;         
      k:=k+1;         
      if (ost >9) and (ost <=36) then
        x:=chr(ost+55)+x         
      else
        x:=inttostr(ost)+x;       
    end;;     
  writeln(x,'  ',j,' ss');   
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?