В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pika4y2
pika4y2
06.10.2020 17:14 •  Информатика

Не могу написать программу на языке паскаль. даны три целых двузначных числа. из наибольшего из них вычесть наименьшее и сравнить результат с оставшимся числом. если полученное число будет больше вывести yes в противном случае no.

Ответ:
кристина2162
кристина2162
02.10.2020 07:31
Var
  a,b,c,max,mid,min,t:integer;
begin
  Writeln('Введите через пробел три целых двухзначных числа');
  Readln(a,b,c);
  if a>b then begin max:=a; min:=b end
  else begin max:=b; min:=a end;
  if max<c then begin mid:=max; max:=c end
  else mid:=c;
  if min>mid then begin t:=mid; mid:=min; min:=t end;
  if (max-min)>mid then Writeln('YES')
  else Writeln('NO')
end.

Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?