В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
denisseleznevdenis
denisseleznevdenis
26.04.2022 02:12 •  Информатика

Дано целое трехзначное положительное число n. составьте программу которая определяет входит ли в него цифра восемь.

Ответ:
муратмурмур
муратмурмур
17.07.2020 00:02
Const ch=8;
var n:integer;
begin
read(n);
while n>0 do begin
if(n mod 10=ch)then begin
writeln('yes'); break;
end;
n:=n div 10;
end;end. 
еще можно в строку преобразовать и посимвольно проверить, но мне кажется так нагляднее и алгоритм проще
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?