В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Viktorua10
Viktorua10
11.03.2023 21:27 •  Информатика

Написать программу, которая получает случайное целое типа int, выводит его двоичное представление на экран, выполняет преобразование в соответствии с вариантом (см. ниже), затем выводит на экран двоичное представление результата преобразования. № варианта пример 1 изменить порядок следования битов в числе на обратный 11010011  11001011 язык си

Ответ:
Gorodnichevavi
Gorodnichevavi
02.10.2020 07:19
Void dvoich(int x1)   {  
srand (time(NULL));   
int i, b;       
long c = 0; 
x1 = rand();       
for(i=0;x1 > 0;i++)       {         
b = x1 % 2;      
x1 = (x1-b)/2;         
c += b * pow(10,i);     }    
printf("\nDvoichnoe chislo: %d",c);   }  
reverse(c.begin(), c.end());
printf("\nDvoichnoe obratnoe chislo: %d",c);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?