В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hers25
hers25
30.12.2022 08:37 •  Информатика

Составить программу в паскаль. вычислить и запомнить значения функции yi=x , если xi< 0 yi=0 , если xi=0 -1 , если xi≤0 где xi - элементы массива из 20 элементов

Ответ:
прапрр
прапрр
16.07.2020 21:06
# include <bits\stdc++.h>
using namespace std;
int main()
{
int x[20], y[20];
int i, n;
cin >> n;
for(i = 1; i <= n; ++i)
cin >> x[i] >> y[i];
if(x[i] > 0)
y[i] = x[i];
if(y[i] == 0) 
x[i] = 0;
if(x[i] <= 0)
puts('-1');
else
cout << x[i] << ' ' << y[i];
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?